Question du C2i : Si la moyenne de l'étudiant Se trouve en A1, laquelle de ces formules indique correctement la situation (refusé, passable ou mention) ?

Si la moyenne de l'étudiant Se trouve en A1, laquelle de ces formules indique correctement la situation (refusé, passable ou mention) ?

Les réponses justes

=SI(A1<10;"recalé";si(A1<12;"passable";"mention"))

Les réponses fausses

=SI(0;"recalé";10;"passable";12;"mention")

=SI(A1<10;"recalé")et si(A1<12;"passable";"mention")

=SI(A1>12;"mention";A1>10;"passable";"recalé")

=SI(A1<12 ;"passable";si(A1<10;"recalé";"mention"))

complément de cours :

Fonctionnement de la fonction SI

La fonction si comporte 3 arguments séparés par des ;

=si(test;ce qu'il faut afficher si test est vrai; ce qu'il faut afficher si test est faux)

Le test est une comparaison du genre A=B ou :

  • A et B peuvent être des références (A1, $A$3....) , ou des valeurs (12
  • le signe de comparaison peut être =, <, >, <= (inférieur ou égal), >=(supérieur ou égal), <> (différent)

les valeurs à afficher peuvent être des chiffres, du texte qui doit être placé entre des guillemets ou des formules. Il est donc possible d'imbriquer des fonction SI pour gérer les situations avec plus de deux possibilités.

Dans la question, il y a 3 possibilités. Si la moyenne est inférieure à 10, si elle est comprise entre 10 et 12 et si elle est supérieur à 12.

Comme il y a 3 possibilité, il faut imbriquer 2 SI (le nombre de SI nécessaire est égal au nombre de possibilité -1)

Le premier va permettre de teste si la note est inférieur à 12

=SI(A1<10;"refusé";

ensuite il faut rajouter le SI qui teste si la note est inférieur à 12

=SI(A<10;"refusé";SI(A<12;"passable";"mention"))

Pour lire une fonction si on remplace le premier point virgule par le mot "alors" et le second par "sinon".

On peut lire : si la note est inférieur à 10 alors "refusé", sinon si la note est inférieur à 12 alors "passable" sinon "mention"

Commentaires

commentaire(s)